GIMP-Forum 3.0

GIMP-Forum 3.0 (http://www.gimpforum.de/index.php)
-   Hilfe und Fragen (http://www.gimpforum.de/forumdisplay.php?f=12)
-   -   .c Plugin auf Windows 10 installieren? (http://www.gimpforum.de/showthread.php?t=24167)

masada213 06.07.2019 15:19

.c Plugin auf Windows 10 installieren?
 
Hallo,
ich war eigentlich nur auf der Suche nach einem Plugin, mit dem ich Farben von 2 Bildern, die zwar das selbe zeigen, aber unterschiedliche Farben haben, zusammenführen kann. Also, dass ein guter Übergang entsteht, oder das eingefügte Bild an die Farbabstimmungen des anderen angepasst wird. Ich habe ein Beispiel hinzugefügt, wo ein Bildausschnitt unten Links in der Ecke eine andere Farbe hat als das restliche. Da will ich, dass das eingefügte Bild die Farben des restlichen annimmt. Wenn ihr da etwas wisst, bin ich euch dankbar.

https://i.imgur.com/DWlDdUe.png

Jedenfalls bin ich dabei auf das Plugin/Skript von elsamuko "Get Curves" gestoßen.
es ist nur eine einzige .c Datei, nur weiß ich nicht wie ich sie installieren soll. Anscheinend kann man diese Dateien über ein Terminal bei Ubuntu/Linux installieren und so steht es auch in dem Skript:
// install with
// gimptool-2.0 --install elsamuko-get-curves.c

Nur wie kann ich die Datei unter Windows 10, Gimp 2.8 installieren?

ursa major 06.07.2019 15:33

Hallo masada213!

Da kann ich nur mutmaßen. Im allgemeinen ist es so, dass man Plugins für GIMP, sofern sie keinen Installer haben, einfach in den Plugin-Ordner kopiert (C:\Users\deinName\AppData\Roaming\GIMP\2.10\plug-ins\). Natürlich entpackt, falls sie sich in einer ZIP befinden sollten. Nach einem Neustart von GIMP sollten sie dann verfügbar sein. Ob das auch für in C geschriebene Plugins zutrifft, weiß ich gerade nicht. Eventuell kann es noch helfen, das Plugin direkt mit GIMP zu verknüpfen. Von GIMPs Einstellungen aus. Das gilt vor allem wenn man Plugins in separate Unterordner packt, was ich zwecks Übersichtlichkeit und Ordnung immer empfehle. Ohnehin ist nicht sicher, dass das Plugin auch in GIMP 2.10... funktionieren wird, weil viele alte Plugins leider nicht damit kompatibel sind. In dem Fall bekommt man entweder beim Start von GIMP schon eine Fehlermeldung, oder beim Ausführen des Plugins. Oder aber es taucht in GIMP einfach nirgends auf.

Ich kenne das Plugin allerdings nicht und kann das daher nicht genau sagen.


Alle Zeitangaben in WEZ +2. Es ist jetzt 02:04 Uhr.

Powered by vBulletin® Version 3.8.2 (Deutsch)
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.