GIMP-Forum 3.0

GIMP-Forum 3.0 (http://www.gimpforum.de/index.php)
-   Alternative freie Software (http://www.gimpforum.de/forumdisplay.php?f=18)
-   -   Tool, welches weiße Ränder um Fotos einfügt? (http://www.gimpforum.de/showthread.php?t=24079)

o0Julia0o 19.02.2019 20:27

Tool, welches weiße Ränder um Fotos einfügt?
 
hi, ich suche ein Tool, welches automatisch weiße Ränder(Größenvorgaben durch Benutzer) um Fotos hinzufügt.


Aber dieses automatisch. So wie IrfanView das kann als Batch/Stapelverarbeitung, da es viele Fotos sind. Ich sehe gerade, dass das mit Irfan-View auch geht: Rahmen hinzufügen.


Jetzt ist es so, dass die Fotos am Ende 9cm*13cm haben sollen. Jedoch kann ich keine cm-Angaben in Irfranview hinzufügen. Nur Pixel. Bei der Bildgröße, welche ich vorher mit Irfranview anpasse, kann ich noch cm angeben. Wie komme ich nun auf die richtigen Werte?



lieben Dank!


Julia :)

ursa major 20.02.2019 13:42

Hallo Julia!

Zunächst mal zu einer Verständnisfrage. Vielleicht weißt Du das schon, aber zur Sicherheit sage ich es nochmal, weil es wichtig ist. Ein digitales Bild hat nicht von sich aus automatisch eine feste Größe in Zentimetern oder Millimetern. Die Größe digitaler Bilder wird immer in Pixel waagerecht x Pixel senkrecht gerechnet. Pixel selbst haben keine feste Größe. Welche Größe Bilder in der physischen Ausgabe haben, hängt immer von der ihnen zugeordneten relativen Auflösung, also einem dritten Wert, ab. Dieser wird zumeist in ppi, also Pixel per Inch (Zoll) angegeben (manchmal auch in dpi, aber das ist nicht richtig, denn dpi steht für "Dots per Inch" und Dots sind die Punkte eines Druckrasters). 1 Inch ist 2,54 cm lang.

Es ist also wichtig, dass Deine Bilder zunächst mal den richtigen Auflösungswert für den Druck haben (wenn sie nicht gedruckt werden sollen ist der ppi-Wert nicht so wichtig). Die Standardauflösung für den Druck ist 300 ppi. Einstellen solltest Du das in einem Dialog wie "Druckgröße" (Menü "Bild") in GIMP, weil er gewährleistet, dass sich dabei die Anzahl der Pixel nicht verändert und die Qualität der Bilder nicht leidet (siehe hierzu die Erklärungen weiter unten).

Zum Umrechnen Deiner Bildgröße bzw. der Größe Deiner Bildränder musst Du aber nicht Deine mathematischen Fähigkeiten bemühen, sondern kannst auch einen Online-Service wie diesen hier nutzen: https://www.blitzrechner.de/pixel-zentimeter-umrechnen/

Worauf ich sicherheitshalber auch noch hinweisen will: Beim Skalieren (vergrößern und verkleinern) von Bildern leidet immer die Bildqualität. Und zwar je stärker und je öfter man es tut, desto mehr. Skaliert man ohne Interpolation, werden die Bilder pixeliger, weil zu den bereits vorhandenen Pixeln einfach andere in den gleichen Farben hinzugefügt (bzw. welche gelöscht) werden. Es wirkt dann beim Vergrößern so, als seien auch die Pixel vergrößert worden. Skaliert man mit Interpolation, werden die Bilder immer etwas unschärfer, weil neue Pixel in Annäherungs- und Übergangsfarben berechnet werden. Das ist aber in den meisten Fällen weniger schlimm als der Verpixelungseffekt. Früher wurde für Digitalfotos immer die kubische Interpolation empfohlen (Linear nur für Grafiken). Mittlerweile gibt es aber auch noch andere, die in manchen Fällen bessere Ergebnisse liefern. Wie z.B. GIMPs "No Halo" und "Low Halo". Im Zweifel kann man Bilder aber auch noch nachträglich etwas nachschärfen. Das sollte man aber immer sorgfältig und vorsichtig machen. Dabei entstehen um Bildinhalte herum nämlich helle und dunkle Ränder (Halos), die man immer so gering halten sollte, dass sie nicht auffallen.

Ob Du das alles nun mit IrfanView, GIMP oder einem anderen Programm machst, musst Du entscheiden. Für GIMP gibt es zwei Plugins, die auch Stapelverarbeitung können: BIMP und David's Batch-Processor. Um die Umrechnerei wirst Du aber auch da nicht herum kommen. Und natürlich ist es in jedem Fall Voraussetzung, dass alle Bilder die gleichen Maße haben.

Wenn es nicht zu viele Bilder sind, könntest Du auch ein neues Bild in GIMP erstellen, das nur den Hintergrund in der Farbe des Rahmens hat und um soviel größer ist als Deine Bilder, wie sie es mit Rahmen wären. Dann könntest Du alle Bilder im Windows Explorer auswählen und in das Bild in GIMP hinein ziehen. Dort würden sie nun als Ebenen übereinander und exakt mittig liegen, und Du könntest das Bild exportieren (z.B. als JPEG oder PNG), dann die oberste sichtbare Ebene unsichtbar schalten und wieder exportieren usw. In dem Fall müsstest Du nicht umrechnen.

o0Julia0o 20.02.2019 16:34

Liste der Anhänge anzeigen (Anzahl: 1)
Danke Dir, ursa major! Das mit dem 3 Abhängigkeiten habe ich inzwischen auch herausgefunden. Verstehen, tue ich es nicht ;) Die Seite habe ich zur Rate gezogen. Aber irgendwie scheint das nicht zu stimmen.


Wenn ich ein Bild auf 9cm*13cm skaliere, dann kann ich 2 Einstellunge wählen:
Größe der Bilder nicht verkleinern: Ja oder Nein


Wenn ich die Größe nicht verkleiner, dann passt das mit den Rändern nicht. Die werden dann total mini. Da stimmt die Umrechnung dann nicht.


Wenn ich sie verkleiner, passt das.


Mein Ziel:
Fotos ausdrucken lassen bei DM, Rossman & Co. in 9*13

https://www.fotoparadies.de/fotos/fotoabzuege.html


Meine Quelle:
Fotos: http://www.gimpforum.de/attachment.p...1&d=1550672906


Wenn ich nun die Option "Größe der Bilder nicht verkleinern" auf Nein setze, dann sehen die Fotos gut aus, und die Randberechnung stimmt ebenfalls, welche ich immer nach der Verkleinerung auf 9*13 mache. Jedoch, wenn ich nur etwas heranzomme, sehen die Fotos super verpixelt aus(also nicht viele, sondern wenige Pixel oder halt viele gleiche nebeneinander).


Da die Randberechnung aber dann möglich ist, meine Frage:
Ist das egal mit dem Pixellook, weil beim DM-Ausdruck man keinen Unterschied erkennen könnte zu dem Foto, wessen Option auf "Größe der Bilder nicht verkleinern" auf Ja steht? Denn bei Ausdruckgröße 9*13 werden identisch viele und große Pixel ausgedruckt. Nur wenn ich jetzt bei DM/Rossman auf 10*13 oder größer drucken wrüde, wäre ein Qualtitäsunterschied Unterschied sichtbar?


Ich hoffe, man versteht einigermaßen, was ich meine.

ursa major 20.02.2019 17:49

Wie die Fotos wirklich aussehen, ob verpixelt oder nicht, kann man auf dem Bildschirm immer am besten beurteilen, wenn man sie in Originalgröße betrachtet. In GIMP muss man dafür nur die Taste "1" auf der Tastatur drücken (in IrfanView 100% in der Zoom-Box). Wenn man in ein Bild hinein zoomt sieht es natürlich immer pixeliger aus als es ist, weil die Pixel dann ja größer angezeigt werden.

Das mit der relativen Auflösung ist eigentlich ganz einfach. Du hast die Breite und die Höhe, die jeweils durch die Anzahl der Pixel definiert sind, aus denen das Bild ja besteht. Nun haben Pixel aber keine feste Größe in Zentimetern/Millimetern. Das kannst Du z.B. daran sehen, dass Du Dir ein und das selbe Bild auf verschieden großen Bildschirmen in seiner Gänze ansehen kannst, ohne dass Du es dafür skalieren oder zoomen musst. Auf den kleineren Bildschirmen sind halt die Pixel kleiner, auf den größeren größer. Mein Bildschirm hat z.B. eine Auflösung von 1920 x 1080 Pixel. Die Bildschirmdiagonale weiß ich grad gar nicht, aber es gibt auch kleinere und größere Bildschirme mit der gleichen Auflösung. Also muss man dem Drucker irgendwie verklickern wie groß die Pixel sein sollen, damit er sie aus der digitalen in die wirkliche Welt herüber holen kann. Und da hat man sich halt für 300 ppi entschieden, weil die Pixel dann so klein sind, dass das menschliche Auge sie nicht erkennen kann, auf der anderen Seite aber auch die Dateigröße nicht unnötig aufgeblasen wird.

Du musst Dir nur mal den Unterschied vorstellen zwischen 300 farbigen Quadraten (Pixeln), die auf eine Strecke von 2,54 cm verteilt sind und 72 farbigen Quadraten auf die gleiche Strecke. In letzterem Fall sind die Pixel mehr als vier mal so groß wie in ersterem. Das ist ein gewaltiger qualitativer Unterschied, zumal man sich halt auch immer klar machen muss was das für die Details des Bildes bedeutet. Pixel sind ja einfarbige Quadrate. Was kleiner als ein Pixel ist kann somit gar nicht dargestellt werden. Und was nur etwas größer ist wird verwaschen und verschoben. Daher ist eine höhere Auflösung immer besser.

Diese Sache mit Rand zufügen habe ich übrigens so noch nie gemacht. Bei einzelnen Bildern schon, aber noch nicht in Stapelverarbeitung und schon gar nicht mir IrfanView. Daher kann ich das jetzt auch nicht so im Detail sagen.

o0Julia0o 20.02.2019 18:12

Dankeschön. Alsol die Quellbilder haben 72dpi 1824*2736 Pixel. Wie man auf dem Bild ja sieht.


Und diese Fotoservices bei DM & Co. drucken in 300 DPI?


Wenn ich also ein Foto verkleinere auf 9*13 - dann sollte ich die Größe beibehalten. Somit hat das Bild ja nicht nachher 224*382 Pixel bie 9cm*13cm Größe. Sondern in etwa genausoviele Pixel.


Und da DM-Fotoservice in 300 DPI ausdruckt, erhalte ich somit bessere Qualität. Weil die 224*382 Pixel auf 72 DPI Qualität sind. Und ich für 300 dann 4,16 fach höhere Pixeldichte benötigen würde, wenn ich auf 300 DPI ausdrucken lasse. Wenn ich also auf dem Bildschirm(72 dpi laut deiner Umrechnungsseite) die Quelldatei(72 DPI) angucke, dann müsste ich 224*4,16 & 382 * 4,16 rechnen. Also 932*1591 Pixel mindestens haben, um keine schlechtere Ausdruckqualität zu haben.


Nur dann bleibt das Randproblem. Mit Gimp alles manuell zu machen, würde Jahre dauern ;)

ursa major 20.02.2019 20:27

Also grundsätzlich braucht man sich um nichts weiter kümmern, wenn man Fotos zum Fotodienst gibt. Da muss man auch die relative Auflösung nicht umrechnen. Darum kümmern die sich. Dein Problem entsteht eigentlich nur dadurch, dass Du einen Rand in Zentimetermaßen hinzufügen willst (wie viel Rand übrigens?).

Das scheiint auch in IrfanView das eigentliche Problem zu sein. Ich habe das gerade mal ausprobiert. Das Bild auf die gewünschten Maße zu bringen ist nicht so das Problem. Aber scheinbar rechnet IrfanView den Rand immer dazu, wodurch die Bilder dann wieder größer werden. Und da das nur in Pixelmaßen möglich ist, ist das ein bisschen komplizierter. Kann man nicht beim Fotodienst auch bestellen, dass die Bilder einen Rand haben sollen?

o0Julia0o 20.02.2019 22:36

Danke. Ich kopiere die fertigen Bilder auf USB_Stick, stecke diesen in den Rossman-Automaten & klicke auf 9*13 ausdrucken. Da kümmert sich Niemand. Die können meine Quelle ja nicht verändern. Einen Rand kann man nicht bestellen. Auf den Rand kommt auch noch etwas drauf. Von daher eh unsinnig. Das gleiche beim Online-Foto-Dienst. Wenn ich zu geringe Auflösung habe, dann kann es zu schlecht sein. Ist die Frage ob meine Berechnung stimmig ist...



Man kann auch negative Werte als Rand eingeben bei Irfanview.

ursa major 21.02.2019 00:13

Ah okay, auf negative Werte bin ich gar nicht gekommen. Dabei ist das naheliegend. Dann sollte das eigentlich kein Problem sein. Außer dass halt vom Bild etwas verloren geht, durch den Rand. Und man muss von Pixel in Zentimeter umrechnen. Wenn ich wüsste wie breit der Rand werden soll, konnte ich das machen. 1 cm Rand z.B. würden bei 300 ppi 118 Pixeln entsprechen.

Auch solltest Du darauf achten, dass Du proportional verkleinerst. Dafür hat IrfanView ja eine Checkbox, die Du anhaken solltest. Andernfalls besteht die Gefahr, dass das Bild leicht verzerrt wird. Du brauchst dann weiter oben eigentlich nur die Breite eingeben, denke ich. Bei den Maßen des Quellbildes wird das Ergebnis eine Kleinigkeit höher als 13 cm. 0,5 cm, wenn ich es recht erinnere. Die müsstest Du dann vielleicht noch vorher abschneiden, sofern das in Irfan View geht. Sonst würde wohl entweder der obere, untere oder beide Ränder schmaler werden als beabsichtigt. Wegen des festen Formats von 9 x 13 cm.

Und wie gesagt wäre es für die Bildqualität wichtig, dass Du nicht zu wild herums kalierst. Verkleinern ist prinzipiell weniger problematisch als vergrößern, aber man sollte es trotzdem nicht übertreiben und möglichst nur einmal machen.

Einen grundsätzlichen Tipp übrigens noch: Man sollte nie die Quellbilder überspeichern. Sonst sind sie verloren, wenn man sie in der Bildbearbeitung verpfuscht.


Edit: Früher konnte man übrigens mal wahlweise die Fotos auch mit weißem Rand bekommen. Habe lange keine mehr bestellt, daher weiß ich nicht wie das heute ist.

o0Julia0o 21.02.2019 20:39

Danke. In der Dateiinfo vom Bild steht 72dpi. Aber DM druckt ja evlt. mit 300 DPI.


Ich orientiere mich aber für den Rand an den 72dpi mit dem Rechner: https://www.blitzrechner.de/pixel-zentimeter-umrechnen/


1cm = 28 Pixel, sagt mir dieser. Ich möchte nun 1cm Rand aufschlagen. Ich gucke mir das Bild danach in Windows10 an mit der Windows-Fotoanzeige(ohne mit dem Mausrad zu zoomen). Der Rand ist aber kleiner als 1cm.

ursa major 21.02.2019 20:45

Du meinst, weil das 0,988 cm sind. Ich denke, dass das daran liegt, weil Pixel unteilbar sind. Daher kommt man oft nicht auf die exakten Werte, sondern meist nur auf Annäherungswerte. Man müsste sonst für manche Zentimeter-Werte von den Pixeln etwas abschneiden können. Und das geht halt nicht. Es sei denn mit einer höheren Auflösung, wodurch die Pixel dann kleiner würden. Ich weiß aber nicht ob Dein Fotodienst damit klar käme. Ist auch eher unüblich. Außer bei Kunstdrucken.

o0Julia0o 21.02.2019 21:02

Nein, eher 0,86cm. Und wenn ich die Auflösung des Monitors verringere sind es 1,18cm.


So komme ich ja nie zu einer richtigen Rechnung....

ursa major 21.02.2019 21:17

Die Auflösung des Monitors dürfte damit eigentlich nichts zu tun haben.

Aber 1 cm bei 72 ppi ist natürlich im Verhältnis zur Bildgröße wesentlich schmaler, weil das Bild mit einer Auflösung von 72 ppi ja wesentlich größer ist (bei schlechterer Qualität). Du kannst zwar ein Bild auch unbearbeitet an den Fotodienst geben. Die Auflösungsumrechnung übernehmen die dann. Aber wenn Du 1 cm Rand zufügen willst, musst Du das natürlich trotzdem im richtigen Verhältnis tun. In dem Fall müsstest Du sie dann auf 72 ppi umrechnen, wenn Du diese unbedingt beibehalten willst. Wie schon gesagt, bei der Umrechnung der Auflösung verändern sich eben gerade die Längenmaße in Zentimetern (nicht die Anzahl der Pixel). Und zwar, wie ich auch schon sagte, um mehr als das Vierfache. Das ist eine Frage der Logik. 1 cm bei 300ppi entsprechen ungefähr 4,163 cm bei 72 ppi. Wie gesagt, "ungefähr" deshalb, weil Bilder immer nur ganze Pixel haben können.


Edit: Was mir gerade durch den Kopf schießt: Du hast doch Deine Bilder jetzt hoffentlich nicht auf 9 x 13 cm bei 72 ppi verkleinert, oder? In dem Fall wäre die Qualität sehr schlecht. Du musst Dir das, wie gesagt, wie ein Mosaik aus lauter kleinen quadratischen Mosaiksteinchen (den Pixeln) vorstellen. Jedes dieser Mosaiksteinchen hat nur eine Farbe. Wenn Du willst, dass dieses Mosaik Fotoqualität bekommt, musst Du dafür sehr viele, sehr kleine Steinchen nehmen, so klein, dass das Auge sie nicht als einzelne Steinchen unterscheiden kann. Für eine Bildschirmdarstellung braucht man aber nicht so kleine Pixel wie für einen Druck, deshalb muss man für den Druck in die höhere Auflösung von 300 ppi umrechnen.

o0Julia0o 21.02.2019 22:45

Jo, danke Major. Also die Quell-Fotos haben 72 dpi. Sehen eigentlich sehr scharf aus, selbst wenn ich hereinzoome.


Wenn ich die hochskaliere auf 300 dpi, keine Ahnung wie das gehen sollte - würde ich ja auch nur an Qualität verlieren.


Ich bleibe bei 72 DPI und lasse DM den Rest machen. Jedoch stimmt die Rechnung nicht. Im Rechner kreutze ich ja 72dpi an. Doch das passt nicht & ist je nach Bildschirmauflösung sehr unterschiedlich(Rand 20mm Unterschied).


Wobei du mal schriebst, dass die Pixel ja unterschiedlich nah beieinanderliegen können - je nach Bildschirm. Würde das nicht diesen Effekt begründen?

ursa major 21.02.2019 23:20

Wo habe ich das denn geschrieben? Nee, Pixel liegen immer direkt nebeneinander. Was Du wohl meinst ist, dass beim Skalieren theoretisch Lücken zwischen den ursprünglichen Pixeln entstehen würden, wenn sie nicht durch neue Pixel gefüllt werden würden, was allerdings grundsätzlich immer der Fall ist. Ein Pixelbild ist wie eine Seite Karopapier aufgebaut. Du kennst die ja sicher noch aus den Schreibblöcken. Da grenzen die Pixel immer direkt aneinander. Beim Skalieren wird im Prinzip dieses "Karopapier" vergrößert oder verkleinert, wobei sich die Größe der Karos/Pixel nicht verändert, die Größe der Seite aber schon. Also müssen neue Pixel hinzu berechnet werden, und zwar so, dass das Bild als solches nicht auseinander gerissen wird. Es werden also nicht einfach nur Pixel außen angefügt, was ja keinen Sinn machen würde, sondern es werden neue hinzugefügt, und alle Pixel des Bildes werden neu berechnet und die "Karos" an den entsprechenden Stellen, wo neue Farbwerte benötigt werden, eben mit diesen gefüllt. Erfordert vielleicht ein bisschen abstraktes Denken um sich das vorzustellen. Wie gesagt, man muss sich das wie ein Mosaik vorstellen.

Im Gegensatz dazu verändert sich bei der Veränderung der Auflösung (also dem dritten Wert in Pixel per Inch) die Größe der Pixel. Wenn man die Auflösung erhöht (z.B. von 72 auf 300 ppi), werden die Pixel kleiner, wenn man sie verringert (z.B. von 300 auf 72 ppi), werden die Pixel größer. Dabei verändert sich allerdings die Anzahl der Pixel nicht. Infolgedessen ändern sich logischerweise die Abmessungen des Bildes relativ zur Auflösung. Mit 72 ppi ist das Bild dann wesentlich größer, aber eben mit einer relativ geringen Auflösung, also in schlechter Qualität (72 Pixel auf 2,54 cm verteilt). Mit 300 ppi ist das Bild kleiner, aber in einer guten Auflösung bzw. Qualität (300 Pixel auf 2,54 cm verteilt).

Das Umrechnen auf 300 ppi macht man in GIMP mit dem Dialog "Druckgröße" im Menü "Bild" (hatte ich auch schon gesagt). Der heißt nicht umsonst so, sondern genau deshalb, weil er für eben diesen Zweck da ist, Bilder auf eine druckbare Auflösung zu bringen, ohne die Qualität zu versauen. Ich weiß nicht genau wie man das in IrfanView macht, weil ich das eigentlich immer nur benutzt habe um mir Bilder anzusehen. Es könnte sein, dass das Skalieren und Umrechnen der Auflösung dort nicht getrennt passiert (was in GIMP auch gemacht werden kann). Dabei hat man allerdings, besonders als Anfänger, weniger Kontrolle über die Bildqualität. Ich könnte Dir im Zweifel auch sagen wie man das in Photoshop macht, denn ich bin seit mittlerweile fast zwanzig Jahren Mediengestalter und kenne mich mit diesen Dingen leidlich aus. Wenn Du aber glaubst das alles besser beurteilen zu können, würde ich Dir raten, das doch einfach so zu machen wie Du willst. Dann brauche ich mir hier nicht sinnlos die Finger wund zu tippen und Du könntest Dich von der Qualität des Resultats einfach überraschen lassen.

CrazyArt79 17.07.2020 21:00

Weisse Ränder & Auflösung
 
Liebe beide

Ich habe die Diskussion per Zufall mitverfolgt und fand diese noch recht spannend. Es wurde sehr viel bereits geschrieben und ich wollte wissen ob man hierzu bereits eine Lösung gefunden hatte?

Den ich sehe oder vielleicht habe ich das durch die vielen Texte übersehen keine Endresultate und es würde mich wundernehmen ob man hierzu eine gefunden hätte.

Denn man kann nur dazu lernen:D Gewisse Topics kommen mir recht bekannt vor, wie zum Bsp. mit der Berechnung und den Naheliegenden Wert, das ist mir auch schon aufgefallen und wie ursa major sagt, stimmt das Haargenau.

Vielleicht hilft diese Info weiter?
"
Haben Sie beispielsweise eine Grafik im Format 1.000 x 800 Pixel erstellt und möchten sie in einer Imagebroschüre abdrucken, so führen Sie folgende Rechnung durch: 1.000 Pixel in der Breite geteilt durch 300 ppi macht 3,33 inch (multipliziert mit dem Faktor 2,54 ergibt das also ca. 8,5 cm)."

:info-64:
Und es gibt einen Recht coolen Artikel darüber unter: https://www.flyeralarm.com/blog/de/d...en-dpi-und-ppi

Die Änderung im GIMP ist auch keine Rocketscience ;O) Unter dem Menü _ Bild – Bild Skalieren – x-Auflösung – y-Auflösung ändern.

Hier ist die Auflösung in GIMP, daher in PPI = Pixel per Inch.

LG,
CrazyArt79

ursa major 17.07.2020 22:44

Hi CrazyArt79!

Für das Umrechnen der Auflösung für den Druck gibt es in GIMP einen eigenen Dialog: "Druckgröße". Bei dem kann man absolut sicher sein, dass sich beim Umrechnen der relativen Auflösung die Anzahl der Pixel des Bildes, und damit seine Qualität, nicht verändert. Man kann das auch mit dem Dialog "Bild skalieren" machen, aber dabei könnten einem leicht Schnitzer unterlaufen, die die Bildqualität eben doch beeinträchtigen.

Aber dieser Thread ist eigentlich auch erledigt. Jemandem etwas zu erklären setzt beim Gegenüber immer auch ein Mindestmaß an Bereitschaft voraus es sich erklären zu lassen. Und das hier ist mindestens der zweite Thread mit dieser jungen Dame, bei dem das nicht der Fall war. Wenn Dich die Frage aber interessiert, mach doch dazu einen eigenen Thread auf. Vielleicht kriege ich die Erklärung diesmal auch besser hin. Oder jemand anderes.

o0Julia0o 18.07.2020 13:15

Also das ist halt ziemlich komplex das Thema. Ich bearbeite alle paar Wochen! mal ein Bild mit Gimp. Für Profis mag das natürlich unkompliziert sein. Naja, man muss ja auch nicht alles verstehen.

ursa major 18.07.2020 15:05

Also eigentlich ist das kein wirklich kompliziertes Problem. Bildern einen weißen Rand zu verpassen ist eigentlich sogar recht einfach. Wenn man es mit IrfanView machen will, ist es vielleicht etwas komplizierter. Ich habe das auch noch nie mit IrfanView gemacht.

Wenn man es mit GIMP machen wollte und der Rand das Bild nicht vergößern soll, könnte man z.B. - wenn es sich um einen ganzen Stapel Bilder handelt - zunächst mal ein Neues Bild mit weißem Hintergrund, den gewünschten Zielmaßen und einer relativen Auflösung von 300 Pixel/Inch erstellen.

Diesem fügst Du dann eine Ebenengruppe hinzu (das ist der zweite Button von links ganz unten im Dialog "Ebenen").

Und in dieser Ebenengruppe öffnest Du dann alle Bilder (Du kannst sie auch aus dem Explorer direkt auf den Eintrag der Ebenengruppe ziehen), die Du in dieser Größe mit dem gleichen weißen Rand haben willst. Dafür sollten sie aber schon eine geeignete Größe haben - eher eine Kleinigkeit zu groß als zu klein.

Dann machst Du einen Rechtsklick auf die Ebenengruppe und klickst im Kontextmenü auf "Ebene auf Bildgröße".

Nun gehst Du in das Menü "Ebene" und klickst auf "Ebenengröße" (es ist wichtig, dass hierbei der Eintrag der Ebenengruppe aktiv ist).

In diesem Dialog gibst Du hinter den dort stehenden Wert für "Breite" und "Höhe" ein Minus und den doppelten Wert der gewünschten Randbreite ein. Dann klickst Du noch auf "Zentrieren" (es sei denn Du möchtest, dass der Rand irgendwo breiter oder schmaler ist - das müsstest Du dann mit dem Versatz zusätzlich regeln) und dann auf "Größe ändern".

Nun sollten alle Ebenen, die in der Gruppe liegen, gemeinsam auf die gleiche Größe zugeschnitten sein und lassen die weiße Hintergrundebene als Rand sehen.

Wenn Du nicht willst, dass für den Rand etwas von den Bildern abgeschnitten wird, kannst Du alle Ebenen der Ebenengruppe auch gemeinsam herunterskalieren, anstatt sie zuzuschneiden. Dazu musst Du nur mit dem Skalieren-Tool auf das Bild klicken (in den Werkzeugeinstellungen muss dabei bei "Transformation" der ganz linke Button - "Ebene" - aktiv sein) und dann oben rechts im "Skalieren"-Dialog bei beiden Werten wiederum ein Minus und den jeweils doppelten Wert der gewünschten Randbreite eingeben. Dann "Skalieren" klicken.

Jetzt kannst Du nach und nach je eine Ebene exportieren (wobei die Hintergrundebene sichtbar sein muss), dann jeweils die oberste sichtbare Ebene unsichtbar schalten und wieder exportieren bis Du alle Ebenen exportiert hast. Als Dateiformat solltest Du das JPEG nehmen. Da es keine Ebenen und Transparenzen unterstützt, wird hier beim Export alles auf eine Ebene mit Hintergrund reduziert.

Eine einfachere Methode fällt mir gerade nicht ein. Sollte es irgendwo haken, gern nachfragen. Vielleicht habe ich ja irgendwas vergessen.

Es gibt sicher im Stapelverarbeitungs-Plugin BIMP auch eine Funktion hierfür. Die weiß ich aber gerade nicht. Müsstest Du Dir also selbst raussuchen. Und wie gesagt, wie das in IrfanView geht weiß ich leider auch nicht.

Zu unserem kleinen Problem, das wir beide hier immer wieder haben: Ich denke nicht, dass es etwas mit Profi und Nicht-Profi zu tun hat. Ich versuche durchaus immer alles möglichst auch für Einsteiger verständlich zu erklären, weil ich selbst schon oft unter diesen Experten-Nerds zu leiden hatte, die scheinbar alles können, aber nichts verständlich erklären können und oft wohl auch nicht wirklich wollen. Aber manches ist eben doch ein bisschen komplexer und bedarf, wenn man es denn wirklich verstehen und beherrschen will, auch ein paar Hintergrunderklärungen. Da braucht es beim Fragesteller dann ein bisschen Konzentration und Bereitschaft sich damit auseinanderzusetzen, wenn es was werden soll. Letztendlich solltest Du Dir auch darüber klar sein, dass der, der Dir da im GIMP-Forum hilft, selbst eigentlich nichts davon hat, wenn Du mit der Sache klarkommst. Ich erwarte deshalb keine Unterwerfung oder sowas, aber wenigstens ein Bemühen darum Fragen nachvollziehbar zu formulieren, nicht gleich auszurasten oder auszusteigen, wenn man mal irgendwas nicht verstanden hat - man kann immer nochmal nachfragen - und möglichst auch Rückmeldung zu geben wenn das Problem gelöst werden konnte. Denn jedes Problem, jede Frage, könnte auch für andere interessant sein. Sonst könnte man jeden Thread auch sofort wieder löschen.

-Michael- 18.07.2020 21:25

Hallo Julia,
habe Dir ein kl. Video erstellt:
https://www.youtube.com/watch?v=N2PB7IkprKg
Keine Angst, aus Datenschutzrechtlichen Gründen habe ich das Video auf meinem Kanal NICHT gelistet.
Kann also nicht ohne Weiteres von jemand Anderen angesehen werden.

ursa major 19.07.2020 00:12

Hi Michael!

Schön gemachtes Video, aber ich fürchte, das ist nicht was ihr vorschwebt. Ihr ging es ja darum einem ganzen Stapel Bilder Rahmen hinzuzufügen. Sie könnte natürlich mehrere Bilder öffnen und dann auf die restlichen Bilder einfach Strg+F anwenden (Filter wiederholen), aber wenn ich mich richtig erinnere wollte sie ja auch nicht, dass die Bilder durch den Rahmen größer werden. Und das macht dieser Filter ja leider.

-Michael- 19.07.2020 11:54

Zitat:

sie ja auch nicht, dass die Bilder durch den Rahmen größer werden. Und das macht dieser Filter ja leider.
Wenn Du mal rechts in die Ebenenleiste schauen möchtest, wird eine gleichgroße Ebene erzeugt, in der sich der Rahmen befindet.


Wenn die Bilder alle gleichgroß sind, kann man diese als Ebenen einfügen, alle Augen schließen(mit SHIFT auf ein Auge klicken) und die Rahmen-Ebene ganz nach oben.
Jetzt kann das Auge der Rahmen-Ebene und des untersten Bildes geöffnet werden.
* als Bild exportieren (Strg+Shift+e)
* einen Namen vergeben / Pfad wählen
* das Auge vom nächsten Bild öffnen
* und wieder exportieren
bis man am obersten Bild angelangt ist. Dann hat jedes Bild den gleichen Rahmen.



Für hunderte Fotos ist diese Vorgehensweise natürlich nichts. Ob das Pix, Gwenview oder XnView können, weiß ich nicht, habe noch nie Rahmen für viele Fotos gebraucht. Habe noch nie Rahmen für EIN Foto gebraucht.

ursa major 19.07.2020 12:16

Hm, ich weiß nicht ob ich Dich richtig verstehe. Jedenfalls habe ich gerade mal ein Bild von 500x500 Pixel Größe mit diesem Filter mit einem Rahmen versehen und hatte danach ein Bild von 700x700 Pixel Größe. Da es da auch weiter keine Einstellungsmöglichkeiten gibt, würde ich das so interpretieren, dass dieser Filter das Bild größer macht.

Wenn Du den Rahmen als erstes erstellst, in der angestrebten Bildgröße, und dann die Bilder als Ebenen darauf ziehst, brauchst Du erstens eigentlich den Filter nicht, denn eine weiße Hintergrundebene würde völlig genügen, und zweitens ist das fast genau der Weg, den ich in meinem vorletzten Post beschrieben habe. Man braucht dabei auch nicht alle Augen schließen (was man übrigens mit gehaltener Shift-Taste auch hinkriegt ohne jedes Auge einzeln anzuklicken), sondern muss nur nach und nach die oberste Ebene ausschalten, damit die nächste zum Vorschein kommt, und dann jeweils exportieren. Der Hinweis, dass man die einzeln exportierten Ebenen beim Exportieren individuell benennen sollte ist aber natürlich wertvoll. Das hatte ich vergessen zu erwähnen. Versteht sich eigentlich von selbst, kann aber nicht schaden das nochmal hervorzuheben.

Aber natürlich überlasse ich es der Thread-Starterin, welchen Weg sie wählen möchte.

Für die Methode mit dem Rahmen-Filter müsste es übrigens auch eine Funktion in BIMP geben, wie ich weiter oben ja auch schon erwähnte. Die würde dann zwar die Bilder vergrößern (siehe meine Ausführungen zum "Rand hinzufügen"-Filter oben), aber wenn man die Bilder vorher entsprechend zuschneidet oder skaliert (also negativ um die doppelte Randbreite), was man ebenfalls mit BIMP tun könnte, dann müsste es gehen. Man müsste nur rausfinden wleches die Funktion in BIMP ist. Ich vermute, dass es sich um script-fu-add-bevel oder um script-fu-addborder handeln muss. Das wäre dann wirklich Stapelverarbeitung und mit wenigen Klicks machbar. Auch übrigens bei hunderten Bildern. Wenn Julia sich dafür noch interessiert, kann sie ja mal Laut geben. Dann könnte ich oder vielleicht auch Du ihr sicher relativ knapp erklären wie das mit BIMP geht.

-Michael- 19.07.2020 13:36

Zitat:

von 500x500 Pixel Größe mit diesem Filter mit einem Rahmen versehen und hatte danach ein Bild von 700x700 Pixel Größe.
In der Tat, die Ebene wird um die Rahmenbreite vergrößert.


Ich kenne Gimp zwar schon seit ca.2002 noch unter WinXP, aber nach BIMP mußte ich eben tatsächlich erstmal suchen.


Naja, gibt ja mittlerweile so viele Scripte und Plugins (z.B. http://www.gimpchat.de), die kann/will man sich gar nicht alle installieren und leider funktionieren viele unter 2.10.x unter Linux nicht mehr so recht (bzw. werden in den entsprechenden Verzeichnissen nicht erkannt).

In G'Mic habe ich gerade eben einen "Rahmen-Generator" entdeckt:
Frames → Frame[Painting]. Eine riesige Auswahl die Rahmen zu erstellen. Allerdings auch hier das Manko: die Ebene wird um den Faktor der Rahmenbreite vergrößert.
Man muß also händich: Bild→Bild skalieren
die Ebene auf die Ursprungsgröße bringen.

Wie gesagt - ich brauche keine Rahmen.

ursa major 19.07.2020 13:48

Ich kenne GIMP erst seit 2004. Damals war ich gerade in meiner Photoshop-Ausbildung und habe mich für alles auf dem Sektor brennend interessiert - sofern es für mich erschwinglich war. Da ging an GIMP natürlich kein Weg vorbei. Diesen Filter "Rand hinzufügen" habe ich so gut wie nie benutzt, so dass ich da auch erstmal nachgucken musste.

Was Plugins und Skripte anbelangt, hast Du recht. Die meisten alten Sachen funktionieren nicht mehr unter 2.10... BIMP aber schon. Und BIMP erlaubt es auf nahezu alle in GIMP implementierten Funktionen zuzugreifen. So kann man also so ziemlich jeden Filter und manch andere Funktion von GIMP gleich auf ganze Ordner voller Bildern anwenden und auch mehrere Operationen in einem Rutsch durchführen. Das ist sehr hilfreich. Leider muss man aber für die meisten Funktionen wissen wie sie auf Englisch heißen. Teils werden da auch komische Kürzel benutzt. So muss man mitunter ein bisschen suchen. Ich habe vorhin einfach mal mein GIMP auf Englisch umgestellt und geguckt wie der Filter da heißt. "Add Border" ist es wohl. BIMP müsste für Dich eigentlich auch interessant sein, denke ich.

An G'MIC hatte ich auch schon gedacht. Julia geht es aber wohl um einfache Passepartouts in Weiß, so dass man G'MIC dafür nicht wirklich braucht. Ob mn G'MIC auch mit BIMP verwenden kann bin ich mir gerade nicht sicher. Ansonsten gehen nachinstallierte Skripte und Plugins aber auch, soweit ich mich erinnere.


Alle Zeitangaben in WEZ +2. Es ist jetzt 02:19 Uhr.

Powered by vBulletin® Version 3.8.2 (Deutsch)
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.