Forum Wiki Galerie Kontakt Wie man Fragen richtig stellt. Tutorial Forum
Zurück   GIMP-Forum 3.0 > RSS-Feeds > GIMP

Hinweise
Alt 22.01.2012, 12:50   #1
Wilber
RSS-Feed-Bot
 
Registriert seit: 27.05.2008
Beiträge: 1.674
Standard [GIMP Registry] - GIMP Book

GIMP Book is a script for managing multiple pages in the GIMP, it's great for creating comic books, illustrated books, sketch books or similar. It opens a separete window with thumbnails of all your pages, where you can add, delete, sort and rename them. Once you're done you can export your book to various formats, for web or print.

IMPORTANT!

This is an early Beta release of GIMP Book. I have only tested it under Ubuntu 10.04 and 11.10, and don't know if it will work on Windows or OSX. Creating a comic book or illustrated book is a lot of work, so make sure you make a backup of all your files regularly!!!

Installation

Download book.py.txt ,and rename it to book.py (GIMP Plugin Registry adds the .txt for some reason). Copy the book.py file into ~/gimp-2.6/plug-ins/. The next time you start the GIMP, you should find it under the Windows menu.

Creating a Book

Start by opening the GIMP, and the GIMP Book interface from the Windows>Book... menu. You'll be presented with an empty Book window, in which you can choose File>New Book (Ctrl-N).

In the Create a New Book dialog, enter a name for your book, size and destination. GIMP Book will create a folder at that destination, with the name of your book, a a couple of subfolders for and a *.book file.

The Template

When you create a book, you'll see a Template.xcf thumbnail show up in your Book window. This is used as a template for all new pages that you add. You can double click it to open it in the GIMP, and make any adjustments to it you like. It's a good idea to spend some time adjusting the resolution, adding print markings, default layers and any other things you may need for the pages of your book. You can adjust the template at any time later, but changes to it, won't affect existing pages.

The template is always shown as the first page of the book. It is numbered as page zero, when exporting, and is not exported by default.

Thumbnail Size

The thumbnails used in GIMP Book, are standard GTK thumbnails. This means that their size is controlled by the GIMP itself. To get bigger thumbnails, got the the Edit>Preferences menu in the GIMP, under Environment, and change Size of thumbnails to "Large (256x256)". This won't affect existing thumbnails until the next time the file is saved, or you delete the thumbnail cache.

Saving Your Book

There is no need to save your book. When you add pages, move them around, or delete them, GIMP Book saves those changes instantly. The only thing you need to save, is the actual GIMP xcf files, when you work on them. The thumbnails for images you've changed and saved, are updated the next time the GIMP Book window receives focus.

Opening an Existing Book

To open a book simply choose File>Open Book... from the Book window, and use the standard open dialog to locate your *.book file. The book will open in the Book window, and you can start working with it. If thumbnails have not been generated for your book (which for instance happens if you move it to a different folder, loading will take a short while as new thumbnails are generated.

To open a page, simply double click it, and it will load in the GIMP.

Managing Pages

At the top of the Book window there is a toolbar with three buttons you can use to manage your pages.

Adding a Page

The first button, is for adding new pages. When you click it you will be asked to give the page a name. You can use a descriptive name, that helps you remember what's on the page. Pagenumbers are added on export, so you don't need to number your pages, unless you want to. New pages are added to the end of the book, if no page is selected, or at the selected page if one is.

Deleting a Page

To delete a page, simply select the page, and hit the delete button. You'll be asked to confirm that you really want to delete the page.

When you delete a page in GIMP Book, it is not deleted permanently, but moved to your_book/trash/date_pagename.xcf, in case you want to get something from it later. You can freely delete the content of your_book/trash, if you want to free up disk space.

Renaming a Page

Select the page you want to rename, and hit the rename toolbutton. Enter a new name, and you're done.

Sorting Pages

To reorder the pages, simply drag them around to where you want them.

Exporting Your Book

Once you're finished with your book, you can export it to several different formats. To do this simply choose File>Export Book... from the menu in the Book window.

Destination Tab

At the top of the tab, you can choose the name of the folder you want to export your book to. GIMP Book will create a new folder with the name of your book at that destination, and fill it with images in the format you specify.

For naming the pages you can choose between using the name of the book (e.g. 1_My Book.jpg), the name of the pages, simply using page numbers with no name, or using a custom name that you enter in the Custom Name field.

You can choose the page range you wish to export. Page 0 is the template, which you probably don't want to include in your export.

Layer Tags

Layer tags are used to hide or show tagged layers. It can be used for doing multi-lingual comics, to hide sketch layers, and so on. To tag a layer simply put any tag between square brackets [] in the layer name. For instance "[en] Speech Buble" or "[sketch] Car Chase". Layers can have multiple tags, but if the tags match both hide and show, show wins.

To hide or show layers, simply enter a comma separated list of tags, without the square brackets [], in the appropriate hide or show field (e.g. "en,de,no,sketch"). On export, layers matching the tag will be hidden or shown, before exporting.

For the remining layers, that don't match any tag, you can choose to either leave their visibility as is, hide or show them.

Margins Tab

On export you can change the margins of your pages. This is similar to Canvas Size in GIMP, but uses relative page margins instead of width and height and an offset. Negative values, vill crop the image, while positive will make the canvas bigger. You can choose between using the background color saved in the image, black, white or a custom color, for the background when you make the image bigger.

Image Size Tab

The image size tab is basically the same as the standard GIMP one. You can choose width or height, as pixels or percentiles, and choose the interpolation method to use. GIMP Book uses the template for you book, to decide the aspect ratio, when choosing scale values.

File Format Tab

You can choose to export your book as a sequence of gif, xcf, jpg, psd, png or tiff files. The save options for the different file formats are basically the same as in GIMP. For xcf and psd, you can choose not to flatten the image, keeping layer data intact to work on the files further.

When you've chosen all your export options, hit the Export Pages button, and GIMP Book will start processing your pages. This can take a short while, as each page needs to be loaded, possibly modified, and then saved out again.

Behin the Scenes

If you just want to use GIMP Book, you can stop reading here. If, on the other hand, you want to know a little bit more about what it does, keep reading.

The File Format

GIMP Book stores the pages of your book in a simple file structure that looks like this.

MyBook/ |-- MyBook.book |-- pages | `-- Template.xcf `-- trash All your pages and the Template are stores in the pages folder as plain .xcf files. Any pages you delete are moved to the trash folder. GIMP Book only touches the xcf files on three occassions, when you add a page a copy is made of the Template file, when you rename a page the xcf files gets renamed, and when you delete a page, it gets moved to the trash folder, and a time and date is added to the name.

The *.book File

The *.book file, is a simple JSON file, that contains a list of your pages, in the order they are shown. When you move pages around, all that happens is that the list of pages in the JSON file is changed. The *.book file keeps no record of pages that have been deleted or anything else at the moment. I may add more features to it in the future, but will try to keep them compatible with the current format.

Any time you do changes, such as move, rename, add or delete a page, the *.book file is automatically updated.

AttachmentSize book.py.txt60.1 KB

Weiterlesen...
Wilber ist offline   Mit Zitat antworten
 

Lesezeichen

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist An.
Smileys sind An.
[IMG] Code ist An.
HTML-Code ist Aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
[GIMP Registry] - Updated PhotoLab script with modified borders and save metadata in Wilber GIMP 0 09.09.2010 06:32
[GIMP Registry] - Inspect Wilber GIMP 0 17.03.2010 16:30
[GIMP Registry] - borders for Gimp 2.0 Wilber GIMP 0 30.10.2009 03:12
[GIMP Registry] - Steel Text (gimp 2.6) Wilber GIMP 0 22.10.2009 09:00
The GIMP 2.2-pre1 (Halloween Release) schumaml Neues von GIMP 2 14.11.2004 20:12


Alle Zeitangaben in WEZ +2. Es ist jetzt 20:23 Uhr.


Powered by vBulletin® Version 3.8.2 (Deutsch)
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.