Forum Wiki Galerie Kontakt Wie man Fragen richtig stellt. Tutorial Forum
Zurück   GIMP-Forum 3.0 > Arbeiten mit Gimp > Tutorials > Grundlagen

Hinweise
Alt 08.06.2005, 11:37   #1
Rebell
Erfahrener Benutzer
 
Benutzerbild von Rebell
 
Registriert seit: 20.03.2003
Beiträge: 1.068
Standard Animationen erstellen (Teil 1)

Hi, my name is Rebell, and this is my second gimp tutorial called "Animationen erstellen" part 1.

Heute will ich dir zeigen, wie man simple Animationen mit Gimp erstellt.


Alles neu macht der Mai
Um eine Animation zu erstellen, lege einfach ein neues Bild an. Die Größe bleibt dir überlassen. Denke nur daran, den
vollen Farbraum zu verwenden (RGB).


Ich bin geblendet
Angenommen wir wollen einfach nur Text erscheinen lassen, dann müssen wir lediglich zur Hintergrundebene (in meinem Fall weiß) eine Ebene anlegen, die es einzublenden gilt (in meinem Fall "Erscheinender Text").
Der Animationssfilter zum Überblenden erwartet immer eine Hintergrundebene, nämlich die unterste. Diese wird beim Überblenden NICHT verändert, sondern nur die Ebenen darüber. Daraus folgen 2 Dinge:
- Du kannst beliebig viele Ebenen überblenden lassen. Dabei überblendet die obere immer die untere.
- Es müssen mindestens 3 Ebenen existieren (2 die überblendet werden sollen, 1 Hintergrundebene)
Da wir den Text aus dem Nichts erscheinen lassen wollen, legen wir dementsprechend einfach eine leere Ebene darunter an.Galeriebild


7*7 = Feiner Sand
Jetzt nutzen wir Gimps geniale Filterskripte. Die findest du unter Script-Fu -> Animation -> Überblenden, danach öffnet sich dieser Einstellungsdialog.
Galeriebild

Wichtig für einmalige Animationen ist, dass das Häkchen bei "geloopt" entfernt wird, sonst würde das Skript den Text ein-, und wieder ausblenden.
Die Anzahl der Schritte bzw. wie lange und detailiert die Überblendung sein soll, legst du bei "Zwischenbilder" fest. Hier sollte man niemals zu großzügig sein, sonst erstellt man Animationen die später fürs Web viel zu groß sind.


. . , - fertig ist das ...
Nach Anwendung des Filters, öffnet sich eine Kopie deines Bildes mit den entsprechend fertig-gerenderten Ebenen. Den Verlauf der Animation kannst du dir über Filter -> Animation -> Animation abspielen anschauen. Einstellungsmöglichkeiten hast du hier aber noch nicht.
Wenn du mit der Animation zufrieden bist, solltest du diesen Stand zwischenspeichern. Da deine Animation jetzt noch viel zu groß fürs Web wäre, musst du nun optimieren. Speichern des Zwischenstandes deshalb, weil die Optimierung sehr stark verlustbehaftet ist.


Pimp my Gif
Nutze nun Filter -> Animation -> Optimieren für Gif. Das Skript verändert deine Ebenen so, dass nur noch die Differenzen zwischen den Einzelbildern gespeichert werden. Somit können teilweise doppelte Farbinformationen verworfen werden, was natürlich jede menge Speicherplatz spart. Zusätzlich erscheinen Zahlen in Klammern hinter den Ebenennamen. Diese geben Auskunft darüber, wie lange diese Ebene still steht, bis die nächste angezeigt wird. Die Ausgangseinstellung ist 100ms, also eine zehntel Sekunde. Die Klammern müssen erhalten bleiben.

Wichtig fürs Gifs ist auch die Einhaltung einer auf 256 Farben begrenzten Palette. Um die Farbpalette zu minimieren und ungenutzte Farben zu entfernen nutze Bild -> Modus -> Indiziert.
Im nachfolgenden Dialog solltest du immer die "Optimierte Palette" nutzen, das bedeutet, dass Gimp versucht die Palette auf die Farben zu begrenzen, die auch tatsächlich im Bild vorkommen. Mit der Zahl rechts daneben kannst du die maximale Anzahl an Farben festlegen. Um so weniger Farben in der Palette, desto kleiner das Bild, aber desto geringer die Qualität. Sollte das Bild mehr Farben haben, als deine Beschränkung, wird Gimp versuchen die fehlenden Farben mit ähnlichen zu ersetzen. Viele Bilder sehen auch mit der Hälfte der Farben noch gut aus.
Galeriebild

Um zu sehen, wieviel Farben das Bild nun tatsächlich verwendet (um gegebenfalls noch weiter zu optimieren) rufst du die Farbpalette über Dialoge -> Indizierte Palette auf. Wie in meinem Bild zu sehen, lag die Grenze bei 256, aber Gimp konnte auf weniger Farben reduzieren.
Galeriebild

Nach dem du die Optimierung erfolgreich durchgeführt hast, sieht das Ganze ungefähr so aus.
Galeriebild

Solltest du mit einem dieser Schritte nicht zufrieden sein, weil vielleicht die Qualität zu gering ist, dann nutze deinen gespeicherten Zwischenstand um von vorn zu beginnen.


Speichern unter...
Um die Animation als Gif zu speichern, benötigst du nur den Dateityp auf "GIF" zu stellen, bzw. der Datei die Endung .gif im Speichern-Dialog zu geben (Beispiel: meine-animation.gif). Gimp wird dich dann Fragen, ob du alle Ebenen vereinen oder als Animation speichern willst. Wähle "Als Animation speichern".
Galeriebild

Als nächstes landest du im Gif-Einstellungsdialog, wichtig sind dort eigentlich nur die Angaben, ob du eine Endlosschleife speichern willst. Ist das der Fall, würde ein Gif-Betrachter (Webbrowser) das Bild unendlich lang wiederholen, andernfalls würde es nach dem ersten Durchlauf gestoppt. Die Pause zwischen den Frames ist nur interessant, wenn du keine explizit für die Ebenen angegeben hast.
Galeriebild


Ergebnis
Galeriebild
__________________
come to daddy, windowlicker!
get m:ke - http://paradies.homelinux.net
Rebell ist offline   Mit Zitat antworten
 

Lesezeichen

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist An.
Smileys sind An.
[IMG] Code ist An.
HTML-Code ist Aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Textur erstellen Peterchen Grundlagen 30 11.01.2014 19:14
Animationen erstellen (Teil 2) Rebell Grundlagen 11 05.09.2006 02:26
Kleine Hilfe zum Erstellen von Texturen flashnfantasy GIMP-Ressourcen 0 03.11.2004 21:31


Alle Zeitangaben in WEZ +2. Es ist jetzt 18:53 Uhr.


Powered by vBulletin® Version 3.8.2 (Deutsch)
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.