Forum Wiki Galerie Kontakt Wie man Fragen richtig stellt. Tutorial Forum
Zurück   GIMP-Forum 3.0 > RSS-Feeds > GIMP

Hinweise
Alt 19.07.2008, 14:20   #1
Wilber
RSS-Feed-Bot
 
Registriert seit: 27.05.2008
Beiträge: 1.673
Idee [MeetTheGIMP] - How to install GiMP 2.5.2 on Ubuntu 8.4

According to billstei in this comments it should work this way:
(This is a compilation of his three postings, I haven’t tried it.)
I was able to compile and install Gimp 2.5.2 (alongside the normal Ubuntu Hardy Gimp 2.4.5, so I have both at once) by following the instructions here: http://www.gimpusers.com/news/2008-0...untu-7.10.html
However I did the following differently:
1) I did not find it necessary to compile GLib or GTK+ as the ones already in Ubuntu Hardy were fine. So I only compiled babl, gegl, and gimp.
2) In step #5 the only export that you need for compiling is this one:
export PKG_CONFIG_PATH=/opt/gimp-2.5/lib/pkgconfig Both the gegl and gimp configure steps will demand that you do that export first, or it will complain that you do not have babl. Make sure that you actually do have the babl you just created installed first, or else it will be correct when it tells you that you don’t have it
Then to run the program I made a shell script like this (per the advice on the Gimp website here: http://gimp.org/release-notes/gimp-2.5.html )
#!/bin/sh PATH=/opt/gimp-2.5/bin:$PATH export PATH LD_LIBRARY_PATH=/opt/gimp-2.5/lib export LD_LIBRARY_PATH /opt/gimp-2.5/bin/gimp-2.5 “$@” Whatever name you give to that shell script file is the one you use to start Gimp 2.5. Remember to do:
chmod +x [whatever-you-called-it] so you can execute it.
3) I prefer to use deb packaging where possible and so I use the program “checkinstall” rather than doing the “sudo make install” step for each of the 3 compiles. Checkinstall is a little buggy at times so you may not want to use it, but if you do here is some advice:
3a) Checkinstall will fail until you create some directories ahead of time (there may be some I missed, but checkinstall will let you know):
sudo mkdir /opt/gimp-2.5/share/locale sudo mkdir /opt/gimp-2.5/share/icons sudo mkdir /opt/gimp-2.5/share/icons/hicolor sudo mkdir /opt/gimp-2.5/share/gimp/2.0/fonts 3b) Checkinstall will list 10 options, and option line #2 is the name of the package itself, which will be by default “gimp”. Since you already have “gimp” installed as Gimp 2.4.5 you will have to change the package name to avoid a conflict, to something like “gimp-2.5? or similar, just so it’s different.
4) Start checkinstall like this:
sudo checkinstall --install=no Then when it finishes you will get a deb, which you can install like this (babl package shown, similar for the others):
sudo dpkg -i babl_0.0.22-1_i386.deb
and of course the advantage is that this will show up in Synaptic if you later decide you want to get rid of it (or upgrade it).
I wish I could say all this is “easy”, but perhaps not. If it seems confusing, then just stick with the original instructions and not mine.
According to the weather report I have a lousy weekend in front of me, (my Croatian friends: it’s afternoon and 16°C in front of my window…..* ) so perhaps I’ll give it a try.
Share This

Weiterlesen...
Wilber ist offline   Mit Zitat antworten
 

Lesezeichen

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist An.
Smileys sind An.
[IMG] Code ist An.
HTML-Code ist Aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
The GIMP 2.2.0 schumaml Neues von GIMP 8 01.07.2006 19:35
The GIMP 2.2-pre2 schumaml Neues von GIMP 11 25.01.2005 19:51
The GIMP 2.2-pre1 (Halloween Release) schumaml Neues von GIMP 2 14.11.2004 19:12


Alle Zeitangaben in WEZ +2. Es ist jetzt 14:23 Uhr.


Powered by vBulletin® Version 3.8.2 (Deutsch)
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.